Omeka_Controller_Plugin_Upgrade

Package: Controller\Plugin

class Omeka_Controller_Plugin_Upgrade

extends Zend_Controller_Plugin_Abstract

Overrides Omeka’s normal routing when the database needs to be upgraded.

Omeka_Controller_Plugin_Upgrade::dispatchLoopStartup(Zend_Controller_Request_Abstract $request)

Set up routing for the upgrade controller.

Only allows authorized users to upgrade, and blocks the public site when an upgrade is needed.

Parameters:
  • $request (Zend_Controller_Request_Abstract) – Request object.
Omeka_Controller_Plugin_Upgrade::_dbNeedsUpgrade()
Omeka_Controller_Plugin_Upgrade::_dbCanUpgrade()
Omeka_Controller_Plugin_Upgrade::_upgrade($request)

Redirect to the upgrade controller.

Parameters:
  • $request (Zend_Controller_Request_Abstract) – Request object (not used).